Виртуальный хостинг

Ошибка 500 Internal Server Error

2013-05-04

Ошибка 500 появляется, когда сервер не может выполнить PHP-код сайта или правила .htaccess из-за ошибок в них. Чтобы её исправить, сначала нужно узнать точную причину.

Где посмотреть причину: "WWW" -> "Журналы" -> выберите сайт -> вкладка "Ошибки". Файлы логов также лежат в каталоге logs.

Ошибка 500 Internal Server Error

Чтобы временно показывать ошибки на страницах сайта, включите "Показывать ошибки" в "WWW" -> "PHP" -> версия сайта -> вкладка "php.ini":

Ошибка 500 Internal Server Error

Или добавьте в .htaccess сайта строку:

php_flag display_errors on

После отладки выключите показ ошибок.